Opened 6 years ago

Closed 4 years ago

#9506 closed defect (fixed)

Size problem with HTTPS Everywhere toolbar button icon when used w/ Firefox

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords:
Cc: rohieb@… Actual Points:
Parent ID: #9511 Points:
Reviewer: Sponsor:

Description

There is a compatibility issue/size problem with the HTTPS Everywhere 3.3.2 toolbar button icon in Firefox 20.0:

The HTTPS Everwhere icon steals vertical pixels, probably because it's oversize or in some other way doesn't respect the size limits that every other icon respects.

It actually steals pixels wherever you place it: If you place it in the menu bar, it increases the vertical height of that. If you place it in the address bar, it increases the height of that. If you place it in the bookmarks bar, it increases that. And if you place it in the status bar (which Firefox 20.0 only keeps if you use the Status-4-Evar add-on), then it increases the height of that.

I've taken a few screenshots to illustrate the problem, which I'll try to attach and also upload to imgur.

  • Screenshot 1 shows the normal situation without the HTTPS Everywhere icon (no pixels stolen). <http://i.imgur.com/SVLIcYf.png>
  • Screenshot 2 shows the HTTPS-E icon in the address bar (bar enlarged; vertical pixels stolen). <http://i.imgur.com/XAdzMzb.png>
  • Screenshot 3 shows the HTTPS-E icon in the bookmarks bar (now *that's* enlarged = pixels stolen from the browser window). <http://i.imgur.com/buy75Jl.png>
  • Screenshot 4 shows Screenshot 1 and 2 superimposed in the GIMP with near 50% transparency, and I used the measuring tool to see how many vertical lines of pixels get stolen from the browser window. It's ten lines that get stolen. (Yes, it looks like an eye disease; the misalignment is of course caused by the stolen pixels.) <http://i.imgur.com/cbl2Wip.png>

For people on smaller resolutions (and you'd be surprised how common 1024x768 and even smaller still is, and not just on smartphones either), again for people with lower resolution screens, vertical pixels, i.e. vertical lines in the browser window are incredibly precious, and every line that's stolen somewhat reduces usability. Also, if every other icon of every other extension/add-on can behave themselves and not steal pixels, then neither should HTTPS-E.

As I'm creating this ticket, HTTPS-E version 3.3.2 isn't listed in your version drop-down list, but that's what my HTTPS=E About window says it is. This may be a typo in either the about window or the drop-down (arguably, that may be another bug).

Child Tickets

Attachments (2)

Screenshots.zip (465.1 KB) - added by cypherpunks 6 years ago.
screenshots 1-4 (zipped)
css.diff (1.8 KB) - added by zyan 6 years ago.

Download all attachments as: .zip

Change History (9)

Changed 6 years ago by cypherpunks

Attachment: Screenshots.zip added

screenshots 1-4 (zipped)

comment:1 Changed 6 years ago by bastik

Component: - Select a componentEFF-HTTPS Everywhere
Owner: set to pde

Changed 6 years ago by zyan

Attachment: css.diff added

comment:2 Changed 6 years ago by zyan

Is this new in 3.3.2? There were some changes from 3.3.1 -> 3.3.2 in the toolbar icon css required to show the number of applied rules and change the color of the icon depending on state. See attached diff file.

comment:3 Changed 6 years ago by zyan

Parent ID: #9511

comment:4 Changed 6 years ago by rohieb

Cc: rohieb@… added

comment:5 Changed 6 years ago by h2j53

Problem still exists with Firefox 23.0.1 (Windows), Firefox 23.0 (GNU/Linux), with HTTPS-Everywhere 3.4.1.

comment:6 Changed 6 years ago by baptx

comment:7 Changed 4 years ago by cypherpunks

Resolution: fixed
Severity: Normal
Status: newclosed
Note: See TracTickets for help on using tickets.