Opened 3 years ago

Closed 3 years ago

#16459 closed defect (not a bug)

[ARM_WARN] The torrc differ from what tor's using

Reported by: bo0od Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: adrelanos@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

hi there , i have installed apparmor profiles but it seems there is a problem.

see the image:-http://i.imgur.com/dIMYcCA.png

the brown message in arm konsole:-

"[ARM_WARN] The torrc differ from what tor's using. You can issue a sighup to reload the torrc values by pressing x.
configuration value is missing from the torrc: RunAsDaemon"

also there r similar reports have been mentioned in the past c this:-

https://trac.torproject.org/projects/tor/ticket/2501
https://trac.torproject.org/projects/tor/ticket/4237

im using debian jessie + tor 4.5.2 + arm version 1.4.5.0 (released April 28, 2012)

Child Tickets

Change History (2)

comment:1 Changed 3 years ago by proper

Cc: adrelanos@… added

comment:2 Changed 3 years ago by atagar

Resolution: not a bug
Status: newclosed

Hi bo0od. That message simply means that tor is currently running with the 'RunAsDaemon' option enabled, but this setting isn't in your torrc. This message is meant to help people who edit their torrc, forget to restart tor, and are then confused why the settings didn't take effect.

I'll either be rewording or dropping the notice in the next release. Iirc Debian does something funky with regard to baking this setting into its tor binary, so in your case it's probably a false alarm due to that.

Note: See TracTickets for help on using tickets.